Assuming you have successfully installed the code snippet for the Product Page Gallery (PPG) feature, as per our Getting Started article, then here are some pointers to help debug the issue:

  • Firstly and most importantly: ensure that you are looking at a Product Page for which you actually have Product Tags linked for your Sauce feed items. If the current product page is not linked to your Sauce items, then nothing will appear.

  • Ensure that your product pages include an HTML canonical tag. We use this tag to find the definitive URL to use for the page - as there are potentially multiple URLs that can lead to the same page (such as the language-specific in the URL, various parameters, or the specific collection which leads to the page for example). Without a canonical tag, the specific URL for the product page used by a customer, may not match what we have recorded.

  • In the HTML canonical tag is missing from your product page, we will fall back to trying to find a matching Sauce Item of yours, which matches the exact URL of one of its hotspots. This will work in many cases, but where it does not - you'd need to work with a developer to get the canonical tag added to your theme.

  • Once you have addressed the above, ensure you refresh your Hotspots by visiting the 'Connected accounts' section of your Sauce account, and scrolling down to click the 'Refresh Product Tags' link. 

If you're still having trouble, then feel to reach out to us at support 👍 

Did this answer your question?